Stamps Label Creation
Incident Report for ShipStation
Resolved
This issue has been resolved and functionality is back to normal.
Posted about 1 year ago. Jun 26, 2017 - 14:58 CDT
Investigating
Stamps.com is currently having issues which is causing errors when getting rates and creating labels. We are working closely with Stamps.com to get this issue resolved as soon as possible. Thank you for your patience.
Posted about 1 year ago. Jun 26, 2017 - 14:56 CDT