Increased UPS response times
Incident Report for ShipStation
Resolved
UPS services have returned to normal operations.
Posted 4 days ago. Nov 09, 2018 - 13:30 CST
Investigating
We are investigating timeout errors when utilizing UPS services.
Posted 4 days ago. Nov 09, 2018 - 12:45 CST
This incident affected: Carrier Integrations.