UPS Mail Innovations Label Creation
Incident Report for ShipStation
Resolved
We have resolved the issue with UPS MailI Innovations label formatting.
Posted 11 months ago. Jan 08, 2018 - 21:09 CST
Identified
Our development team has identified an issue with UPS Mail Innovation label creation (no return address showing on the label). We are in contact with UPS and working on a resolution.
Posted 11 months ago. Jan 08, 2018 - 15:30 CST