Stamps.com Service Issue
Incident Report for ShipStation
Resolved
Stamps.com services are operating normally at this time.
Posted 9 months ago. May 18, 2017 - 13:27 CDT
Monitoring
Stamps.com is no longer generating errors for getting rates and creating labels. We are continuing to monitor these services.
Posted 9 months ago. May 18, 2017 - 12:06 CDT
Investigating
We are currently experiencing errors when using Stamps.com. This is causing us to see errors when getting rates and creating labels. We are working closely with Stamps.com to get these issues resolved as soon as possible. Thank you for your patience.
Posted 9 months ago. May 18, 2017 - 10:49 CDT