Select Users unable to login
Incident Report for ShipStation
Resolved
We have resolved the issue and all users should be able to access the application normally.
Posted about 1 month ago. Jan 15, 2019 - 08:20 CST
Identified
We have identified an issue where select users are unable to login to ShipStation or its related services. We are working to address the issue and will update again once the issue has been resolved.
Posted about 1 month ago. Jan 15, 2019 - 03:00 CST
This incident affected: ShipStation.