ShipStation Login Issue
Incident Report for ShipStation
Resolved
This incident has been resolved. For any remaining concerns, please email us at support@shipstation.com.
Posted Nov 04, 2022 - 14:27 CDT
Update
We are continuing to investigate this issue.
Posted Nov 04, 2022 - 14:27 CDT
Investigating
We are currently investigating an issue preventing merchants from logging in to ShipStation
Posted Nov 04, 2022 - 14:22 CDT
This incident affected: ShipStation.