Stamps.com label printing and rating delays
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted 10 days ago. Oct 08, 2019 - 12:00 CDT
Identified
Stamps.com is reporting issues which may impact label creation and rating through their services.
We are monitoring the situation.
Stamps.com statuspage can be found here: https://status.stamps.com/
Posted 10 days ago. Oct 08, 2019 - 10:25 CDT
This incident affected: Carrier Integrations.