Phone Support Outage
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Mar 28, 2022 - 11:20 CDT
Update
We are continuing to monitor for any further issues.
Posted Mar 28, 2022 - 10:26 CDT
Monitoring
We are currently monitoring a 3rd party outage preventing Support from receiving and making outbound calls.

The chat option is still available to contact us if immediate assistance is needed.

Thank you for your patience.
Posted Mar 28, 2022 - 10:24 CDT
This incident affected: Support Services (Phone Support).