General Slowness
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Jul 05, 2022 - 16:53 CDT
Monitoring
The issue has been identified and resolved. We are monitoring the results.
Posted Jul 05, 2022 - 15:53 CDT
Investigating
We are currently investigating an issue causing general slowness.
Posted Jul 05, 2022 - 14:46 CDT
This incident affected: ShipStation.