Issues with label creation for Stamps.com & Endicia
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 14:52 CDT
Investigating
We are currently investigating an issue affecting label creation for Stamps.com and Endicia services. We apologize for the inconvenience and will provide updates as they are available.
Stamps.com status page: https://status.stamps.com/
Endicia status page: https://status.endicia.com/
Posted Jun 01, 2020 - 13:35 CDT
This incident affected: Carriers (Stamps.com).