ShipStation Slowness
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Jul 22, 2021 - 09:37 CDT
Update
We are continuing to investigate this issue.
Posted Jul 22, 2021 - 09:36 CDT
Investigating
We are currently investigation an issue causing slowness generating labels and packing slips within ShipStation accounts. This is being investigated further now.
Posted Jul 22, 2021 - 08:31 CDT
This incident affected: ShipStation.