Endicia Maintenance
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Mar 08, 2020 - 00:53 CST
Monitoring
The Endicia service will be undergoing scheduled maintenance Saturday, March 7, from 9-10pm (PST). During this time you may experience brief periods of intermittent service disruption. We apologize for any inconvenience. For more information, please refer to Endicia’s status page here: https://status.endicia.com/incidents/9rhpbhjwrh1x
Posted Mar 07, 2020 - 20:16 CST
This incident affected: Carriers (Endicia).