USPS Compliance Requirements
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted May 27, 2022 - 15:02 CDT
Monitoring
USPS has made new requirements for international shipments effective immediately. To ensure that you do not encounter an error when creating an international label, and that your packages are not returned by USPS and properly delivered to its intended destination, please make sure of the following:

-Recipient name is at minimum a first + last name or company name
-All fields have at minimum 2 characters
-Customs Description has 2 or more characters
-Customs Description is not set as “NA” or “N/A”
-All ship from/return address fields are properly filled out
Posted May 16, 2022 - 14:29 CDT