Login Issues
Incident Report for ShipStation
Resolved
This issue has been resolved.
Posted 6 months ago. Apr 08, 2019 - 11:15 CDT
Monitoring
We have identified the issue and have implemented a solution. We are monitoring this situation.
Posted 6 months ago. Apr 08, 2019 - 11:00 CDT
Investigating
Some users are currently experiencing issues when attempting to login. We are currently investigating the issue.
Posted 6 months ago. Apr 08, 2019 - 10:30 CDT
This incident affected: ShipStation.