Endicia Label Services
Incident Report for ShipStation
Resolved
Endicia’s system issues have now been resolved.
Posted 10 months ago. Dec 15, 2017 - 12:13 CST
Identified
Some users are currently seeing issues when creating labels with Endicia Labels Services. Endicia is aware and working to resolve it as quickly as possible.
Posted 10 months ago. Dec 15, 2017 - 11:11 CST