Increased response and login time
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted 7 months ago. Oct 25, 2018 - 10:47 CDT
Update
We have identified and resolved the issue.
Posted 7 months ago. Oct 25, 2018 - 10:47 CDT
Investigating
We are currently investigating an issue causing longer than normal response times that may also affect the ability to log in for some accounts.
Posted 7 months ago. Oct 25, 2018 - 10:39 CDT
This incident affected: ShipStation.