Carrier Issues
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted May 02, 2024 - 10:27 CDT
Investigating
ShipStation is aware of the technical issues impacting Canada Post. We are actively investigating the status of these issues and will provide updates as they become available.
Thank you for your patience!
Posted May 02, 2024 - 09:50 CDT
This incident affected: Carriers (Canada Post).