Canada Post Service Disruption

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 17:03 CDT

Monitoring

Canada Post is working to stabilize their applications after their recent system upgrade, some applications will be unavailable, or customers may experience delays, until further notice.

More info: Visit the Canada Post Service Interruption Page
Posted Jul 03, 2025 - 18:33 CDT
This incident affected: Carriers (Canada Post).