Login Issues
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Oct 22, 2024 - 12:25 CDT
Investigating
We are currently investigating an issue affecting some merchants' ability to log in to ShipStation. This is a top priority for our teams - we will post an update here when we have one. Thank you for your patience!
Posted Oct 22, 2024 - 12:20 CDT
This incident affected: ShipStation.