Parcelforce ShipStation Carrier Services
Incident Report for ShipStation
Resolved
This issue has been resolved.
Posted Oct 13, 2022 - 04:30 CDT
Identified
We are investigating an issue creating labels with Parcelforce services through the wallet.
Posted Oct 12, 2022 - 08:13 CDT
This incident affected: Carrier Integrations.