Label Generation Issue
Incident Report for ShipStation
Resolved
This incident has been resolved. Thank you for your patience.
Posted Oct 20, 2022 - 11:00 CDT
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience. You can keep up to date here: https://status.stamps.com/
Posted Oct 20, 2022 - 09:20 CDT
This incident affected: Carrier Integrations.