Label Creation Slowness
Incident Report for ShipStation
Resolved
Label Creation times have returned to normal.
Posted 4 months ago. May 06, 2019 - 12:25 CDT
Investigating
We are aware of an issue impacting label creation through Endicia services. We will update this page once we are made aware the issue has resolved. Please see Endicia's status page for more information: https://status.endicia.com/
Posted 4 months ago. May 06, 2019 - 12:10 CDT
This incident affected: Carrier Integrations.