Carrier Issues
Incident Report for ShipStation
Resolved
Thank you for your patience while our integrators worked to resolve your issues.
Please refresh your browser to reflect the changes made.

Thank you for your patience and understanding.
Posted Jul 25, 2024 - 16:09 CDT
Investigating
ShipStation is aware of the technical issues impacting UPS rates. We are actively monitoring the status of these issues and will provide updates as they become available.
Thank you for your patience!
Posted Jul 25, 2024 - 10:40 CDT
This incident affected: ShipStation, Carrier Integrations and Carriers (UPS).