ShipStation App Slowness

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 04:56 CDT

Investigating

Please be advised that we are currently investigating time-out issues being reported by our customers who advised that they are experiencing issues logging in to ShipStation and or creating batches or labels.

Our developers are working on a resolution as we speak, and we will update you as soon as possible.

We thank you for your patience and understanding in this matter

Thank you,
ShipStation
Posted Apr 07, 2025 - 22:33 CDT
This incident affected: ShipStation.