Stamps.com - Errors during label creation
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 16:46 CDT
Investigating
We’re experiencing an elevated level of errors with Stamps.com and are currently looking into the issue.
Posted Oct 19, 2020 - 14:28 CDT
This incident affected: Carriers (Stamps.com).