DHL Express label creation and rate issues

Incident Report for ShipStation

Resolved

We were able to work with DHL to correct the issue. DHL Express functionality has returned to normal.
Posted Oct 21, 2019 - 16:06 CDT

Investigating

We are currently investigating reports which are causing users being unable to create labels or get rates with DHL Express services.
Posted Oct 21, 2019 - 10:30 CDT
This incident affected: Carrier Integrations.