ShipStation Performance
Incident Report for ShipStation
Resolved
This incident has been resolved. Thank you for your patience!
Posted Sep 11, 2023 - 11:31 CDT
Update
The issue with ShipStation Connect has been mostly resolved. Pusher will have additional maintenance tonight and Sunday night. If you experience issues printing through ShipStation Connect during the following times, please download your labels as PDF and print directly to your printers. Thank you for your patience!

Scheduled maintenance:
Friday, 9 Sep 2023 04:00 UTC to 06:00 UTC
Sunday, 11 Sep 2023 04:00 UTC to 06:00 UTC
Posted Sep 08, 2023 - 15:49 CDT
Update
We are continuing to monitor this issue. If you are still seeing issues, please press the Refresh Connection button in Connect and log out and back in to resolve. Thank you for your continued patience!
Posted Sep 07, 2023 - 13:04 CDT
Update
Pusher has updated their status page to all clear, but we are still seeing some lingering issues which our team is addressing. When this has been fully resolved, we will notify here.
Posted Sep 07, 2023 - 11:06 CDT
Update
Thank you for your patience! Our team is working on the issue and Pushers team is also monitoring. You can stay up to date with Pushers incident here: https://status.pusher.com/
Posted Sep 07, 2023 - 09:47 CDT
Update
We are continuing to investigate the ShipStation Connect issues that were experienced yesterday. In the meantime, please continue to press the Refresh Connection button in Connect in order to resolve. Thank you for your continued patience!
Posted Sep 07, 2023 - 08:58 CDT
Monitoring
ShipStation was experiencing performance-related issues surrounding ShipStation Connect, creating labels in batches, and printing out packing slips.
We have deployed an update that we are monitoring, in order to have this fix applied, please refresh the web page, uninstall and reinstall ShipStation Connect, and select the "Refresh Connection" button on the newest version of ShipStation Connect.

Thank you for your continued patience during this situation!
Posted Sep 06, 2023 - 13:37 CDT
This incident affected: ShipStation.