ShipStation Connect
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Dec 21, 2021 - 17:05 CST
Investigating
We are investigating an issue regarding ShipStation Connect and printing via Windows PC. The issue is being investigated now and we'll provide follow up information as soon as possible.

At this time we recommend printing via PDF if printing through ShipStation Connect is unsuccessful.
Posted Dec 21, 2021 - 13:33 CST
This incident affected: ShipStation.