Carrier Issues
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 13:48 CST
Investigating
ShipStation Engineers are aware of the technical issues impacting UPS from ShipStation. We are actively working to resolve this issue and will provide updates as they become available to us.
Thank you for your patience!
Posted Nov 20, 2023 - 12:43 CST
This incident affected: Carriers (UPS).