Stamps Outage
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Mar 08, 2021 - 14:31 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2021 - 14:29 CST
Identified
Stamps.com has identified the issue and we are awaiting a fix. Updates are available on https://status.stamps.com/. We will continue to monitor and update as soon as we have more information.
Posted Mar 08, 2021 - 14:19 CST
Investigating
We are currently receiving multiple reports of label creation failing. We have reached out to Stamps.com and they are aware of the issue and working to resolve it as soon as possible. Please check back for updates regarding this issue.
Posted Mar 08, 2021 - 13:11 CST
This incident affected: Carriers (Stamps.com) and Carrier Integrations.