Duplicate package option

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 13:28 CDT

Identified

We are aware of an issue with the duplicate package option for multi-package shipments and are working on a fix.
Posted Jul 14, 2026 - 12:09 CDT
This incident affected: ShipStation.