Ship From Address Error - "Incomplete pickup address"
Incident Report for ShipStation
Resolved
A fix has been implemented and this incident is now resolved.
Posted May 09, 2023 - 15:23 CDT
Identified
The source of this issue has been identified, and we are working towards getting a fix fully implemented.

We appreciate your patience in the meantime as we work towards resolving this issue.
Posted May 09, 2023 - 14:32 CDT
Update
We are receiving reports that this is affecting some label creation. This is a top priority for our teams. We will update here when we have more information.
Posted May 09, 2023 - 13:52 CDT
Investigating
We are currently experiencing an issue with editing or saving Ship From addresses. This should not be affecting label creation. This is currently being investigated, we appreciate your patience in the meantime!
Posted May 09, 2023 - 13:18 CDT
This incident affected: ShipStation.