Degraded performance for ShipStation services.
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted May 13, 2020 - 12:54 CDT
Investigating
We are aware of and currently investigating reported issues related to slow label processing speeds and general UI responsiveness. We will provide updates as they are available and apologize for any inconvenience.
Posted May 13, 2020 - 10:23 CDT
This incident affected: ShipStation.