ShipStation Slowness / Unable to Load

Incident Report for ShipStation

Resolved

Thank you for your patience while ShipStation engineers worked to resolve issues with app slowness and performance. All reports from affected users have assured us that this issue has been fully resolved. Please reach out to ShipStation Support if you are still experiencing issues.
Posted Dec 08, 2025 - 15:14 CST

Investigating

ShipStation is aware of the technical issues impacting page performance on the ShipStation web application. We are actively working to resolve this issue.
We will provide updates as they become available to us. Thank you for your patience!
Posted Dec 08, 2025 - 14:25 CST
This incident affected: ShipStation.