Phone Support Currently Unavailable
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted May 18, 2023 - 23:17 CDT
Investigating
ShipStation is currently encountering issues with our Phone Lines, which is preventing our Users from connecting with our Support Agents. This is currently being monitored, and can be followed here: https://status.zendesk.com/
We appreciate your patience in the meantime!
Posted May 18, 2023 - 18:32 CDT
This incident affected: Support Services (Phone Support).