DHL eCommerce unresponsive
Incident Report for ShipStation
Resolved
We have corrected the issue and DHL eCommerce services are now fully operational.
Posted Jan 18, 2022 - 11:07 CST
Identified
We have identified the issue and are implementing a solution currently.
Posted Jan 18, 2022 - 09:53 CST
Investigating
We are currently investigating an issue which is preventing users from using DHL eCommerce services.
Posted Jan 18, 2022 - 09:47 CST
This incident affected: Carriers (DHL eCommerce).