Shipsurance degraded performance
Incident Report for ShipStation
Resolved
We have confirmed with Shipsurance that the root cause of the intermittent issues has been resolved. We appreciate your patience in this matter.
Posted Dec 20, 2019 - 15:54 CST
Investigating
We are experiencing intermittent issues with Shipsurance purchases. We are working with them to resolve the issue.
Posted Dec 18, 2019 - 18:30 CST
This incident affected: Integrations (Shipsurance).