Issues with label creation for Stamps.com

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted May 28, 2020 - 19:36 CDT

Update

We are continuing to investigate this issue.
Posted May 28, 2020 - 19:32 CDT

Update

We are continuing to investigate this issue.
Posted May 28, 2020 - 18:45 CDT

Investigating

We are currently investigating an issue affecting label creation for Stamps.com. We apologize for the inconvenience and will provide updates as they are available.
The Stamps.com status pages can be found here: https://status.stamps.com/
Posted May 28, 2020 - 18:33 CDT
This incident affected: Carriers (Stamps.com).