Royal Mail Label Creation

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 08:59 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2025 - 08:15 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 04, 2025 - 07:36 CST

Update

We are continuing to investigate this issue.
Posted Mar 04, 2025 - 07:08 CST

Investigating

ShipStation is investigating reports of issues with Royal Mail label creation.

We will provide updates as they become available to us. Thank you for your patience!
Posted Mar 04, 2025 - 06:40 CST
This incident affected: Carriers (Royal Mail).