DPD - Service Temporarily Unavailable
Incident Report for
ShipStation
Resolved
DPD have resolved the issue on their end.
Posted
Nov
29
,
2022
-
06:48
CST
Identified
DPD have responded to advise they are looking into issues on their end and hope to have it resolved as quickly as possible.
Posted
Nov
29
,
2022
-
06:17
CST
Investigating
We are currently investigate an issue with users unable to create DPD labels and have contacted them for more information.
Posted
Nov
29
,
2022
-
06:10
CST
This incident affected: Carrier Integrations and Carriers (DPD).
×
Subscribe to Incident
Subscribe to updates for
DPD - Service Temporarily Unavailable
via . You'll receive .