Login Issues
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 14:16 CDT
Update
We are continuing to investigate this issue. Thank you for your continued patience!
Posted Sep 26, 2024 - 13:17 CDT
Investigating
We are currently aware of the issues impacting some merchants' ability to log in to ShipStation. This is a top priority for our teams. We will have updates for you as soon as they are available.
Posted Sep 26, 2024 - 12:16 CDT
This incident affected: ShipStation.