UPS Issues
Incident Report for ShipStation
Resolved
Thank you for your patience throughout this issue. The UPS issues impacting users' ability to ship and receive rates have been resolved! Please contact our support team if you are still experiencing related issues.
Posted Nov 29, 2023 - 13:20 CST
Monitoring
Thank you for your patience throughout this issue. We are monitoring UPS and will update you as more information becomes available.
Posted Nov 29, 2023 - 13:02 CST
Investigating
ShipStation is currently experiencing performance-related issues with UPS services. We are aware of the impact this has on you, and we are working with UPS to identify the issue! We will provide frequent updates on our progress. Thank you for your continued patience, and check back soon!
Posted Nov 29, 2023 - 12:05 CST
This incident affected: Carriers (UPS).