Rate Latency

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 14:56 CST

Monitoring

A fix has been implemented and we are monitoring the results
Posted Feb 20, 2026 - 14:45 CST

Identified

We are currently investigating issues causing slowdown in pulling rates for ShipStation Carriers - our team is working to resolve the issue.
Posted Feb 20, 2026 - 12:38 CST
This incident affected: ShipStation and Carrier Integrations.