Degraded Performance: Orders Page Loading & Imports

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 08:13 CDT

Investigating

We are investigating reports of some merchants seeing their Orders page stuck in loading state. Our engineering team is working to restore full functionality
Posted Apr 08, 2026 - 16:29 CDT
This incident affected: ShipStation.