Slowness for some ShipStation users

Incident Report for ShipStation

Resolved

We have resolved the issue leading to degraded performance for some of our users. Thank you for your patience.
Posted Aug 17, 2020 - 11:01 CDT

Investigating

We are currently investigating an issue causing some users to encounter degraded performance for ShipStation services. We will provide an update as soon as we know more. We apologize for the inconvenience.
Posted Aug 17, 2020 - 10:47 CDT
This incident affected: ShipStation.