Canada Post - Label Errors
Incident Report for
ShipStation
Resolved
This incident has been resolved.
Posted
Apr
05
,
2021
-
12:59
CDT
Investigating
We have received reports that Canada Post is experiencing issues and returning label errors. We are investigating further.
Posted
Apr
05
,
2021
-
12:31
CDT
This incident affected: Carriers (Canada Post).
×
Subscribe to Incident
Subscribe to updates for
Canada Post - Label Errors
via . You'll receive .