Endicia - Label Creation performance issues.
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Feb 26, 2020 - 14:54 CST
Update
We are continuing to work on a fix for this issue.
Posted Feb 26, 2020 - 13:50 CST
Identified
Endicia is currently investigating an issue where some users are not able to print labels. You can view their status page here: https://status.endicia.com/
Posted Feb 26, 2020 - 13:48 CST
This incident affected: Carriers (Endicia).