12 Month API Key Generation

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 16:09 CDT

Update

We are continuing to monitor for any further issues.
Posted Mar 09, 2026 - 15:49 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2026 - 15:49 CDT

Identified

We are aware of an issue impacting users ability to generate v1 API keys with an expiration date set to 12 months.

The cause has been identified, and we expect a fix to be released later today.
Posted Mar 09, 2026 - 10:53 CDT
This incident affected: ShipStation Companion API (Companion API V1).