Stamps.com increased response times
Incident Report for ShipStation
Resolved
Stamps.com has resolved the issue. Response times have returned to normal
Posted Dec 02, 2019 - 13:38 CST
Identified
Stamps.com is reporting that they have identified an issue which may temporarily affect some users ability to print postage and shipping labels. This may also manifest with higher than normal error rates and response times. We are monitoring the situation. For more information, please consult their status page: https://status.stamps.com/
Posted Dec 02, 2019 - 11:10 CST
This incident affected: Carriers (Stamps.com).