Carrier Issues

Incident Report for ShipStation

Resolved

This incident has been resolved; affected merchants have confirmed that rates are now reflecting appropriately.
Posted Jul 25, 2025 - 13:31 CDT

Monitoring

A fix has been applied, and we are now monitoring the results. Thank you for your continued patience.
Posted Jul 25, 2025 - 12:37 CDT

Identified

ShipStation has currently identified an issue where users' negotiated rates from UPS are not accurately reflected in ShipStation. We are actively working to resolve this issue and will provide updates as they become available to us.
Thank you for your patience!
Posted Jul 25, 2025 - 11:37 CDT
This incident affected: Carriers (UPS).